Outlook 2016 and Exchange 2007 or SBS 2008 support
Home / Windows / Outlook 2016 and Exchange 2007 or SBS 2008 support
27 November 2015, by , in Windows, Comments off

It appears Microsoft have now removed support for Exchange 2007 within Office 2016/Outlook 2016.

Traditionally Microsoft only support the latest three versions of Exchange which for Outlook 2016 are:

Exchange 2016
Exchange 2013
Exchange 2010

Anything other than this will not work, and you will get the following message:

“The resource that you are trying to use is located on an unsupported version of Microsoft Exchange. Contact your e-mail administrator for assistance.”

We recommend downgrading to Office 2013 for Exchange 2007.

About author: